UGA Boxxx

つぶやきの延長のつもりで、知ったこと思ったこと書いてます

Babel

【Bable】@babel/polyfill は非推奨になったらしいので対応する

@babel/polyfill がBabel 7.4.0で廃止されたため非推奨になっていた babeljs.io @babel/polyfill の代わりに core-js を使用することがお勧めされている https://babeljs.io/docs/en/babel-preset-env#usebuiltins core-jsを使う async/await用にregenerator…

【Babel】.babelrcとbabel.config.jsの違い

Babel7にアップデートの際に、参考にしたドキュメントがbabelの設定をbabel.config.jsに記載していた これまで.babelrcに記載したのでどう使い分けるのか調べてみた https://babeljs.io/docs/en/config-files#6x-vs-7x-babelrc-loading 上記のドキュメントに…

【Babel】7.4.0で推奨されているcore-js@3がIE11でうまく動作しない

Babel7では、polyfillは@babel/polyfillからcore-js@3を使うことが推奨されている これに対応したのだがcore-js@3を使ったpolyfilではvuexがIE11でうまく動作しなかった uga-box.hatenablog.com 以下のエラーがでて画面が真っ白になってしまう [vuex] vuex r…